Extra9 - NAVA Expansion Kits

Discuss mods, hacks, tweaks, etc.

Re: Extra9 - NAVA Expansion Kits

Postby gwpt » Dec 20th, '20, 02:28

Thanks KlangGenerator,
My case is still in bubble wrap, so I hadn't noticed them yet!
gwpt
 
Posts: 6
Joined: Feb 26th, '20, 22:19

Re: Extra9 - NAVA Expansion Kits

Postby lytrix » Jan 28th, '21, 19:18

I've also filled in the form to order an Extra9 kit last week. Hopefully one step closer to reach 50 buyers!
lytrix
 
Posts: 2
Joined: Jan 28th, '21, 19:10

Extra 9 Hihat humming problem

Postby plaque@aon.at » Jun 5th, '21, 06:11

Hello there!
I am almost finished with the E9 mod.
Nava was tested without mod: perfect.
Everything works fine with the mod, but when i switch in the filter on the Hihat, it basically works (HP/BP/LP) but with terrible hum on it, changing a bit when turning cutoff or envelope on the E9. Sounds a bit like a grounding problem...
I built a second E9 pcb - with exactly the same behavior. I built it very carefully.

Has anyone had similar issues. Or already got the HH filter working on the E9?

Thank you very much for all comments!!!
plaque@aon.at
 
Posts: 11
Joined: Jan 17th, '21, 12:11

Re: Extra9 - NAVA Expansion Kits

Postby gihaume » Jun 6th, '21, 16:23

gihaume
 
Posts: 293
Joined: May 12th, '14, 14:48

Re: Extra9 - NAVA Expansion Kits

Postby plaque@aon.at » Jun 11th, '21, 14:19

@gihaume
Thank you! With another powersupply most of the hum is gone.
There is still some humming depending on the position of cútoff and envelope potentiometers....not a psu problem any more..
Someone wrote: "At last I had to change some resistors value to get the HH filter quiet. I replaced R71 for a 10K, R72 for a 200K and R86_2 for a 10K. This lower the level reduction to the filter input and the filter output at the same time."

Do i really need to modify the HH Filter circuit to get the signal clean?

Also, when i switch the filter in there is always a loud "click" like there is DC on it....is that normal, or does the filter switch in silently on your device?

Thank you!!!
plaque@aon.at
 
Posts: 11
Joined: Jan 17th, '21, 12:11

Re: Extra9 - NAVA Expansion Kits

Postby serum114 » Jul 6th, '21, 15:03

plaque@aon.at wrote:@gihaume
Thank you! With another powersupply most of the hum is gone.
There is still some humming depending on the position of cútoff and envelope potentiometers....not a psu problem any more..


You should ground the enclosure also. The circuit will still be a little noisy but this the S-P filter.
serum114
 
Posts: 188
Joined: Mar 6th, '17, 18:18

Previous

Return to Nava Mods

Who is online

Users browsing this forum: No registered users and 2 guests

cron