Trouble updating the Firmware (v1.019)

Discuss use it and firmware update

Trouble updating the Firmware (v1.019)

Postby crisp » Nov 5th, '16, 22:24

I am starting to go a bit nuts here. I have tried several permutations and nothing works.

1-Downloaded MidiOx

2- Changed both buffers to 64 bytes with Channel 32 (Under Options-->Configure Buffers) **Not sure what the Channel # should be...so I just kept it at 32**

3- Dowloaded the .rar file

4- Uncompressed/unzipped .rar file

5- Connect cheap Midi/USB interface to computer. MIDI OUT of the device to Midi IN of the NAVA

6- From drop down menu View--->> Sysex--->>> Command window ---> Load file---->(Pick 1.019 .syx) --->> Command window--->Sendsysex

7-Hold down 1+3+5 on NAVA while turning on the power

8- From drop down menue Command window --->> Sendsysex

9-Progress bar shows progress. USB/MIDI device stars blinking it's blue light

10-Nava does nothing until upload is complete. No status meter or flossingl lights. Step number one lights up and stays lit.

11-Upon completion of the send the NAVA restarts and the display shows the old 1.018 version.

I have done this about 20 times with little changes here and there. What am I missing? I really want my Mid-Tom fixed.

Thank you,
Steve
Last edited by crisp on Nov 6th, '16, 00:21, edited 1 time in total.
crisp
 
Posts: 7
Joined: Nov 5th, '16, 21:55

Re: Trouble updating the Firmware (v1.019)

Postby crisp » Nov 5th, '16, 23:23

I may have found the culprit, and it is not with the NAVA.

I believe the problem stems from the garbage USB/MIDI cable that I purchased. I figured that since I never use MIDI, and would only be using the adapter for intermittent firmware updates, I bought one of those cheap interfaces off of evilbay.

I finally found this website. Took apart my so called "interface", and it looks EXACTLY the same. :roll:

http://www.arvydas.co.uk/2013/07/cheap-usb-midi-cable-some-self-assembly-may-be-required/

Even though the little egg has a blue light blinking as it "Sends" the sysex, I believe it is being corrupted somehow or not being sent in the correct format. As a result the NAVA knows something is happening, but does not understand it. That explains while it still knows to reboot when the data ceases uploading, but doesn't know what to do with said data.

Chinese knockoffs +1

Me +0

Don't make the same mistake.

I feel like an idiot. :|
crisp
 
Posts: 7
Joined: Nov 5th, '16, 21:55

Re: Trouble updating the Firmware (v1.019)

Postby Reggiechacha » Nov 16th, '16, 14:53

I thought I was having the same issue and so upgraded my USB/midi cable. The Nava flashes when the new firmware is loading but when done it still says v1.018 and there are no changes. I've tried midiox, mios and c6 but no joy.
Anyone have any ideas why the firmware doesn't change/upload?
Reggiechacha
 
Posts: 15
Joined: Aug 21st, '16, 16:41

Re: Trouble updating the Firmware (v1.019)

Postby pistrix » Nov 30th, '16, 02:17

Similar problem, very strange symptoms.

I have two Nava's, each was running firmware 1.018.

One Nava was successfully updated to 1.020 using Bome's SendSX, with the sending speed set to the slowest speed, using an EMU USB to MIDI adaptor with both MIDI In & MIDI Out connected to the Nava. It succeeded on the 2nd or 3rd try.

The other Nava I have tried sending the latest firmware (1.020) repeatedly -- dozens of times now, using all sorts of settings in Midi OX and Bome's SendSX. It refuses to update -- it completes the sysex send successfully (it resets after led's for steps 9,6,5, and 3 are lit), but remains 1.018 version.

I have been attempting to send the sysex from both the EMU adaptor that previously worked, as well as a PreSonus Firewire interface. Nothing seems to work.

I thought perhaps there is some error somehow with the Nava that wouldn't update. So I swapped the ATMega1284P's. The 1.020 version ATmega chip was successfully transplanted into the Nava that wouldn't update. The 1.018 Atmega chip that wouldn't update was transplanted to the Nava that successfully updated the other Atmega to 1.020. But the remaining 1.018 Atmega still won't update in either Nava. It doesn't make any sense.

Could it be that one ATmega chip is missing a bootloader or some such thing, and the other was not?
pistrix
 
Posts: 66
Joined: Jan 6th, '14, 09:19

Re: Trouble updating the Firmware (v1.019)

Postby Reggiechacha » Dec 6th, '16, 18:53

interesting, so it looks like the Atmega is the cause, or the boot loader isn't there.
I've tried and tried again using different sysex software. Very frustrating.
Reggiechacha
 
Posts: 15
Joined: Aug 21st, '16, 16:41

Re: Trouble updating the Firmware (v1.019)

Postby pistrix » Dec 9th, '16, 04:24

I strongly suspect that there is something wrong with our ATMEGA1284p, but I'm not experienced enough to be certain.

I have an Arduino Uno I've been trying to use as an ISP, to erase and re-program the 1284P that won't accept the sysex firmware update, but I have had no success. I'm using Arduino IDE 1.0.1. I've got the 1284P properly set-up on a breadboard and wired to the Arduino as directed on the maniacbug 1284p page here: https://maniacbug.wordpress.com/2011/11 ... ga1284p-4/ -- except that I have no separate FTDI or USB to TTL interface, and am unclear if I need one? With the ArduinoISP sketch loaded on the Arduino, I can use avrdude and read the 1284P and see it's current fuse settings. But the IDE won't burn the Mighty1284p bootloader (fails verification). Attempts with avrdude to manually change fuse bytes fail verification and they simply remain the same. Attempts to upload the 1.017 firmware source files with Arduino IDE 1.0.1 throws up loads of errors just during the code compile, before even attempting upload. Any tips appreciated...very new to Arduino..
pistrix
 
Posts: 66
Joined: Jan 6th, '14, 09:19

Re: Trouble updating the Firmware (v1.019)

Postby redstorm » May 30th, '19, 15:16

Im here to say that i successfully updated nava firmware via "cheap chinease usb-midi cable" with the following settings:

1. Latest Linux OS
2. Increasing sysex interval to 20ms.

So the command line should looks like this (you can list your devices with "amidi -l" command):

amidi -p hw:1,0,0 -i 20 -s Nava_v1_023.syx

The nava was flashed successfully after increasing "sysex interval" to 20ms. (I tried also 5ms.. 10ms.. and all that fails).
Just wanted to share this "upload firmware" instruction to make life easier for everyone.
redstorm
 
Posts: 26
Joined: May 18th, '16, 13:09

Re: Trouble updating the Firmware (v1.019)

Postby gihaume » May 31st, '19, 08:25

There are a few, to not say a lot of, MIDI/USB interfaces which can fail to transmit SysEx. I specifically use a Midiman/M-audio Midisport for all SysEx firmware shits because I'm sure it works.
gihaume
 
Posts: 244
Joined: May 12th, '14, 14:48


Return to Nava Software

Who is online

Users browsing this forum: No registered users and 1 guest