NAVA 95% Complete, couple of questions. [UPDATE now 100%]

Discuss Nava construction and related issues

NAVA 95% Complete, couple of questions. [UPDATE now 100%]

Postby TEAMBANZAI » Oct 12th, '19, 18:00

Hello!

Been lurking here for some time and finally got ahold of a kit/enclosure from a person who did not have any time to make it themselves.

I am 95% done with the build, it is a v1.0l and I have successfully implemented all the fixes posted in the forums (including switching C153/154 to 10uf for better output levels). Currently waiting on my mux boards (any day now, they shipped almost 4 weeks ago) to get the eeprom instruments working.

The questions I have are:

- The bom includes the screws for the enclosure, and seems to have extras for the rubber feet, but there were no rubber feet on the mouser bom. Any suggestions or links to some feet that screw into the enclosure? It is not the Erica Synths enclosure and has holes on the bottom for feet.

- Is the latest firmware 1.28beta or 1.28? The way it is listed on the forum it seems like the beta fixes an issue with the 1.28 but its not 100% clear to me on that. Either way my Nava updated to the 1.28beta without any issues so thats a plus.

- I did a test with some CD4051 in IC111 and IC114 to make sure the eeprom instruments did in fact work. The ride and crash worked but still no hihat. I assume this is due to the removed caps? but wanted to double check.


So far this thing sounds like a beast and aside from no eeprom instruments yet has no issues with functionality.

Cheers!
Last edited by TEAMBANZAI on Nov 11th, '19, 16:47, edited 1 time in total.
TEAMBANZAI
 
Posts: 7
Joined: Oct 12th, '19, 17:34

Re: NAVA 95% Complete, couple of questions.

Postby TEAMBANZAI » Oct 15th, '19, 09:57

Mux boards arrived today, got them soldered and all the voices play which is cool. I am getting the Open hat decay issue that others seem to have. Once the caps arrive I will try implementing Loons parallel cap addition to see if that helps: via this thread - http://www.e-licktronic.com/forum/viewtopic.php?f=24&t=2064&p=12124&hilit=hat+decay#p12124

I decided to go with these rubber feet from Amazon: https://www.amazon.com/gp/product/B07PHZZ436/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

As well as the suggested power supply:
https://www.amazon.com/gp/product/B00B8865BG/ref=ppx_yo_dt_b_asin_title_o08_s00?ie=UTF8&psc=1
TEAMBANZAI
 
Posts: 7
Joined: Oct 12th, '19, 17:34

Re: NAVA 95% Complete, couple of questions.

Postby KlangGenerator » Oct 15th, '19, 11:20

Unlike the recent Nava enclosure from Erica Synths, the very first run of cases from user "happymum" had four 3.5mm holes to fix these rubber feet:

https://www.mouser.de/ProductDetail/bud-industries/f-7800-a/?qs=fEIo6Qrfg29FRxS1CjwHIA==&countrycode=DE&currencycode=EUR

They were removed from the BOM but I am still using them for the Erica Synths case:

Image
User avatar
KlangGenerator
 
Posts: 338
Joined: Aug 8th, '16, 16:36

Re: NAVA 95% Complete, couple of questions.

Postby TEAMBANZAI » Oct 16th, '19, 18:26

KlangGenerator wrote:Unlike the recent Nava enclosure from Erica Synths, the very first run of cases from user "happymum" had four 3.5mm holes to fix these rubber feet:

https://www.mouser.de/ProductDetail/bud-industries/f-7800-a/?qs=fEIo6Qrfg29FRxS1CjwHIA==&countrycode=DE&currencycode=EUR

They were removed from the BOM but I am still using them for the Erica Synths case:

Image


Very cool! Thank you for that, if the rubber stick-on ones don't work for me I will grab those.
I finished the build today using Looms advice and tested a few different caps in parallel with Muxboard IC111 C6. I landed on using a 10nf ceramic and the hihats now have their decays back. I also added the 6.8nf cap to Muxboard IC114 C6 for the kick decay and it seems to have beefed up the kick as well.

Very happy with this build. Once the Chia Shin knobs arrive the whole package will be complete! :D
TEAMBANZAI
 
Posts: 7
Joined: Oct 12th, '19, 17:34

Re: NAVA 95% Complete, couple of questions.

Postby TEAMBANZAI » Nov 11th, '19, 16:46

Finished it all up last night. Took a bit longer than expected since I had some new through hole muxboards made up at oshpark since the SMD mux boards would just not function properly no matter what I tried. Tested every point for continuity, replaced ICs and made sure there were 0 bad solder joints/bridges/etc and they still would only work 70% of the time. These new Muxboards worked the first time, and I have had no accent issues since. Also installed the secondary noise source v3 by michigan synthworks for the handclap.

Image

The Chia Shin knobs are fantastic, if you are going to build a kit, definitely snag a set from KlangGenerator.

Image
TEAMBANZAI
 
Posts: 7
Joined: Oct 12th, '19, 17:34

Re: NAVA 95% Complete, couple of questions. [UPDATE now 100%

Postby goodrevdoc » Nov 27th, '19, 23:16

hey pretty cool, are those boards shared on oshpark? lot of folks here could use them...
goodrevdoc
 
Posts: 28
Joined: Feb 17th, '16, 04:09

Re: NAVA 95% Complete, couple of questions. [UPDATE now 100%

Postby TEAMBANZAI » Nov 29th, '19, 13:18

goodrevdoc wrote:hey pretty cool, are those boards shared on oshpark? lot of folks here could use them...


http://www.e-licktronic.com/forum/viewtopic.php?f=26&t=2122
TEAMBANZAI
 
Posts: 7
Joined: Oct 12th, '19, 17:34


Return to Nava Hardware

Who is online

Users browsing this forum: No registered users and 2 guests