Page 1 of 4

Yoctov1.0 Firmware Update.

PostPosted: Apr 29th, '15, 18:36
by e-licktronic
Dear Diyer,

Here you can find last Yocto Sysex Update:

    v1.0c:
      -Fix Midi slave sync
      -Fix Trig CPU in MIDI slave mode
    v1.0b:
      -Add Solo mode by holding mute button in mute mode (solo exclusive)
      -Fix bug CPU trig (Rimshot and Cowbell trig Fixed)
      -Improve button reading in pattern mode
    v1.0a:
      -Fix triggers outs to V-TRIG
      -Fix roll function in Master mode
    v1.0:
      -First release

Yocto_v1_0c.rar
(37.37 KiB) Downloaded 808 times

Yocto_v1_0b.rar
(14.11 KiB) Downloaded 764 times


Best regards,
e-licktronic

Re: Yoctov1.0 Firmware Update.

PostPosted: Apr 29th, '15, 20:44
by BastienL
Great! Thanks for the update.
I'll flash my atmeg asap to try this out!

Re: Yoctov1.0 Firmware Update.

PostPosted: May 1st, '15, 10:18
by Acid303
Hi,

after uploading 1.0b i have issues with the accent/trigger behaviour mainly with the rimshot and the cowbell. They are very soft/quiet. I first thought that it is a hardware problem so I posted in the hardware section first.

After reuploading the old firmware everything worked fine again. Accent as usual...perfect.

Do other users of 1.0b have the same behaviour?

Thanks...

Re: Yoctov1.0 Firmware Update.

PostPosted: May 5th, '15, 10:49
by stu-urns
Hi there,

I'm not sure whether I've managed to get the latest firmware loaded on my Yocto (I'm new to this :oops: ).

I can't seem to get solo mode going, which suggests to me I haven't managed to load the latest software.

I get two kicks in "Init EEp" mode, with the reset button pushed.

When I try to upgrade the device using sysex, what feedback should I expect from the device?

Re: Yoctov1.0 Firmware Update.

PostPosted: May 5th, '15, 13:02
by BastienL
Hi guys,

I uploaded the new firmware and everything is working right, no strange behaviour of the accent, trigs are now V-trig and the solo function works well too.
Stu-urns, you have to hold 1,3 and 5 while turning the yocto on, it should be ready to receive sysex now.
When uploading the new firmware, the 8 first steps shows the progression of the upload (in binary i think), when the 8 steps are lit, it's finished.
Hope you'll succeed in upgrading your yocto!

And thanks vincent for the new firmware version!
My next request is to have the hability to sequence trigs with midi in expander mode, that would be so great!

Re: Yoctov1.0 Firmware Update.

PostPosted: May 6th, '15, 10:50
by stu-urns
Hey BastienL,

Thanks for your advice.

When I try and send the sysex only one LED on the yocto lights up - so I guess it isn't upgrading properly.

I'm using a cheap USB2.0-MIDI cable, which probably isn't the best. Tried with both Sysex Librarian on Mac OSX and MIDI-OX on Windows 8. I mucked around with the speed settings, but still it's not upgrading.

I'll re-try tomorrow with my friend's good quality MIDI interface.

Re: Yoctov1.0 Firmware Update.

PostPosted: May 7th, '15, 23:53
by kluber
Great! Finally! 8-) 8-) 8-)

Re: Yoctov1.0 Firmware Update.

PostPosted: May 8th, '15, 07:43
by stu-urns
Quick update - re-tried updating my Yocto with a decent midi interface (Roland UM-2) and it worked first time. Used Sysex Librarian on a Mac.

Let that be a lesson to all the other n00bs - the cheap USB - MIDI cables don't work for sysex transfers!

Re: Yoctov1.0 Firmware Update.

PostPosted: May 18th, '15, 23:33
by dac
I used SysEx Librarian on a Mac sending over Focusrite USB interface. I needed to slow transmission speed down to 25% (setting is in the preferences tab for SysEx Librarian) in order for the Yocto to read the dump. Even then it took several tries to get the dump to work. The first time I thought I had successfully upgraded the firmware I was getting my rimshot triggering at about 10% the volume it was previous to the dump. I think it is working fine now... I did another dump and the rim sounds much better. V-trig is working too!

On an unrelated note, is there an easy way to dim the LEDs on the Yocto? Is there a resistor change or are they being controlled in software? The LEDs feel like they are burning holes in my eyes at the current brightness!

Re: Yoctov1.0 Firmware Update.

PostPosted: May 20th, '15, 19:31
by olli
will you please release the sources of that last version?