TUTO: How to burn Yocto v1.0 Bootloader with an ArduinoISP

Discuss use it and firmware update

Re: TUTO: How to burn Yocto v1.0 Bootloader with an Arduino

Postby Altitude » May 26th, '16, 11:53

^
thanks!
User avatar
Altitude
 
Posts: 147
Joined: May 28th, '15, 13:01

Re: TUTO: How to burn Yocto v1.0 Bootloader with an Arduino

Postby ricenpeas » Jun 21st, '16, 20:38

I am unable to load the Yocto board into the Arduino IDE 1.6. It is asking for a board manager URL. Does anyone know what that is?
ricenpeas
 
Posts: 9
Joined: May 22nd, '16, 02:12

Re: TUTO: How to burn Yocto v1.0 Bootloader with an Arduino

Postby nroos » Jul 27th, '16, 17:02

I am also having similar issues on OSX getting the board to show up in Arduino IDE. I have tried both 1.6.4 which has the new board managing features and 1.0.6 which does not. I made the hardware folder in (arduino package contents > contents > hardware) and unzipped the yoctoboot file . This I believe is the correct folder. I also tried in documents/arduino/libraries but it didn't work either. Is there anywhere else I should try?
nroos
 
Posts: 2
Joined: Jul 27th, '16, 16:41

Re: TUTO: How to burn Yocto v1.0 Bootloader with an Arduino

Postby nroos » Jul 28th, '16, 16:32

Good news. Got the board to load into arduino. Needed to install an older version of arduino (1.0.6) but it immediately recognized the yocto file. I think that has something to do with the addition of the board managing feature. The correct file is as instructed at the top of this thread. Must make an additional folder titled hardware in Documents/Arduino. Hope that gets things working for ya.
nroos
 
Posts: 2
Joined: Jul 27th, '16, 16:41

Re: TUTO: How to burn Yocto v1.0 Bootloader with an Arduino

Postby goodrevdoc » Nov 4th, '16, 07:45

Having an issue with this. When I run bootloader, i get this error message:
avrdude: stk500_getsync(): not in sync: resp=0x15
Using Arduino Uno, 1.0.6, OSX, connections between the boards are good and correct. Any Ideas? Im not well versed in Arduino stuff, so im not prepared to rule out something im doing wrong. Thanks,
-Jusitn
goodrevdoc
 
Posts: 27
Joined: Feb 17th, '16, 04:09

Re: TUTO: How to burn Yocto v1.0 Bootloader with an Arduino

Postby halides » Nov 8th, '16, 12:28

goodrevdoc wrote:Having an issue with this. When I run bootloader, i get this error message:
avrdude: stk500_getsync(): not in sync: resp=0x15
Using Arduino Uno, 1.0.6, OSX, connections between the boards are good and correct. Any Ideas? Im not well versed in Arduino stuff, so im not prepared to rule out something im doing wrong. Thanks,
-Jusitn


I had lots of issues like this. My problem coming from a long past in embedded dev was that when Arduino says "Pin" it means the connector on the board, not the actual pin on the microprocessor!

This is my current setup which works with UNO:

https://drive.google.com/file/d/0BwhkfL ... tEYU0/view

Orange wire is ICSP SCK, UNO Digital ouput 13
Brown wire is ICSP MISO, UNO Digital output 12
Yellow wire is ICSP MOSI, UNO Digital output 11
Green wire is ICSP Reset, UNO Digital output 10
Blue wire is GND
Red wire is +5V

I actually used this to flash the project itself from Arduino, not the .hex or .syx.

Hope it helps,
.p
User avatar
halides
 
Posts: 72
Joined: Aug 24th, '16, 13:05

Re: TUTO: How to burn Yocto v1.0 Bootloader with an Arduino

Postby richardlawson1489 » Dec 30th, '16, 07:09

Thanks for sharing the information. I found the good arduino UNO from amazon.
richardlawson1489
 
Posts: 31
Joined: Feb 18th, '15, 09:59
Location: Anaheim

Re: TUTO: How to burn Yocto v1.0 Bootloader with an Arduino

Postby iceman1981 » Jan 20th, '18, 14:18

thx for sharing this information.
iceman1981
 
Posts: 7
Joined: Jan 20th, '18, 13:30

Re: TUTO: How to burn Yocto v1.0 Bootloader with an Arduino

Postby pistrix » Oct 15th, '18, 02:40

Just a reminder for Arduino UNO users (and some other Arduino models as well..)

Connect your Arduino as shown in the tutorial and Program/Upload the ArduinoISP program.

But then, before proceeding to Burn the bootloader, add a 10uf capacitor between Reset and Gnd on your Arduino. Without this step, Burning the bootloader will fail.
pistrix
 
Posts: 66
Joined: Jan 6th, '14, 09:19

Re: TUTO: How to burn Yocto v1.0 Bootloader with an Arduino

Postby The_Menestrel » Dec 5th, '18, 21:55

Hi all!

I just finished the build of my Yocto 808 v1.
I wanted to update the firmware via sysex bu it didn't work.
I followed all the step, and burned the bootloader.
Then i uploaded a firmware using midi and it didn't work.
I could see the led blink while it was loading and then nothing...
Can anyone help me to figure what is not working?

Thanks
The_Menestrel
 
Posts: 1
Joined: Dec 5th, '18, 21:42

Previous

Return to Yocto v1.0 Software

Who is online

Users browsing this forum: No registered users and 1 guest

cron