Unoffical Firmware Available

Discuss use it and firmware update

Re: Unoffical Firmware Available

Postby FlavioB » Mar 8th, '20, 21:08

FactoryDefault wrote:
rv0 wrote:Interesting. Looks like the future-retro swinx can do it.


Exactly - Swinx is the device!
F.
FlavioB
 
Posts: 185
Joined: Aug 16th, '15, 19:51

Re: Unoffical Firmware Available

Postby rv0 » Mar 9th, '20, 21:04

oer23 wrote:-I tried to update my firmware with RV0 1.2C version. I used Midi-OX (with 200ms delay). But I don't know if it did something, I made on my Nava and when I did the update the LED light up with a sequence, on the Yocto the LED still off, is it normal? How I can know if the update was done?

sounds like it didn't update

did you see any led animation while updating?
Get the latest unofficial Yocto V1 firmware here.
Be sure to check the revised manual.
Leave your comments in this thread.
User avatar
rv0
 
Posts: 184
Joined: Feb 11th, '14, 09:09

Re: Unoffical Firmware Available

Postby oer23 » Mar 10th, '20, 17:42

No LED animation when I made the update, they still stayed off...
I used my A9 Native Instru sound card for this update. I used the same card to made an update with my Nava (without 200ms delay) and it worked well.
On your link there is 2 files, one ".hex" and one ".sys", I just sent the ".sys".
oer23
 
Posts: 16
Joined: Feb 24th, '16, 20:37

Re: Unoffical Firmware Available

Postby rv0 » Mar 10th, '20, 18:28

oer23 wrote:No LED animation when I made the update, they still stayed off...
I used my A9 Native Instru sound card for this update. I used the same card to made an update with my Nava (without 200ms delay) and it worked well.
On your link there is 2 files, one ".hex" and one ".sys", I just sent the ".sys".


No LED animation can mean 3 things:
- Midi cables not OK
- You didn't follow the update instructions and/or were not quick enough
- Your CPU does not have a bootloader
Get the latest unofficial Yocto V1 firmware here.
Be sure to check the revised manual.
Leave your comments in this thread.
User avatar
rv0
 
Posts: 184
Joined: Feb 11th, '14, 09:09

Re: Unoffical Firmware Available

Postby oer23 » Mar 10th, '20, 21:33

For the cable, I used 2 differents.
The CPU came with the E-liktronic kit Yocot V1, but I don't know if it have a bootloader (I'm a big newby with Arduino).
For the update instruction: I turn on the Yocto with 1.3.5 switch hold on, I upload the ".sys" in Midi-OX en send the file with 200ms delay (we can see the midi output of the sound card make the transfer).
Here is for me.
Do I have make something with the ".hex" file? For the moment I use just the ".sys" for the update.
Thanks for your quick answer.
oer23
 
Posts: 16
Joined: Feb 24th, '16, 20:37

Re: Unoffical Firmware Available

Postby rv0 » Mar 11th, '20, 19:36

@oer23

CPU will be fine.
Just make sure the cable works (e.g: does midi slave work)

When turning on the yocto you have to start sending the .syx within 5 second.

Ignore that .hex
Get the latest unofficial Yocto V1 firmware here.
Be sure to check the revised manual.
Leave your comments in this thread.
User avatar
rv0
 
Posts: 184
Joined: Feb 11th, '14, 09:09

Re: Unoffical Firmware Available

Postby oer23 » Mar 11th, '20, 21:04

When I used Yocto in slave it work.
Ok thanks for the info, I will test a new update later.
oer23
 
Posts: 16
Joined: Feb 24th, '16, 20:37

Re: Unoffical Firmware Available

Postby Masuto » Mar 12th, '20, 10:13

ok guys.. definitely would like to do it right.
i have my brand new arduino UNO, i have a brand new blank ATMEGA 1284P.
installed the Arduino's old 1.0.6 IDE, and i am reading Vincent's guide here http://www.e-licktronic.com/forum/viewtopic.php?f=17&t=436.
I have downloaded the github folder https://github.com/HomoElectromagneticus/Yocto_808
I unpacked the github folder on the same place as Arduino's.
I followed all the guide steps, at step 7 i also put a 10uF capacitor between reset and ground on the Arduino.
The Bootloader gets burned correctly.
Then i click FILE/SKETCH FOLDER/yocto_808-master/yocto; tools/arduino type/here i tried with either UNO or Yocto 808 16mhz but neither of the two works when i try to upload the file: it tells me

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.
Arduino: 1.0.6 (Windows NT (unknown)), Board: "YOCTO Boot 16MHz"
Yocto:290: error: 'Serial1' is not a type
Yocto:290: error: 'MIDI' has not been declared
Yocto:290: error: expected constructor, destructor, or type conversion before ';' token
Yocto.ino: In function 'void setup()':
Yocto:318: error: 'Timer1' was not declared in this scope
Yocto:320: error: 'Timer3' was not declared in this scope
Yocto:326: error: 'MIDI' was not declared in this scope
Yocto:326: error: 'MIDI_CHANNEL_OMNI' was not declared in this scope
Yocto:331: error: 'SR' was not declared in this scope
Yocto.ino: In function 'void Chenillard()':
Yocto:356: error: 'SR' was not declared in this scope
Yocto:360: error: 'SR' was not declared in this scope
BPM_fonction.ino: In function 'void Check_BPM()':
BPM_fonction:37: error: 'Timer1' was not declared in this scope
BPM_fonction.ino: In function 'void TestTapeTempo()':
BPM_fonction:128: error: 'Timer1' was not declared in this scope
Check_Edit_Button.ino: In function 'void Check_Edit_Button_Pattern_Edit()':
Check_Edit_Button:24: error: 'SR' was not declared in this scope
Check_Edit_Button.ino: In function 'void Check_Edit_Button_Pattern()':
Check_Edit_Button:169: error: 'SR' was not declared in this scope
Check_Edit_Button.ino: In function 'void Check_Edit_Button_Setup()':
Check_Edit_Button:260: error: 'SR' was not declared in this scope
Check_Edit_Button.ino: In function 'void Check_Edit_Button_Song()':
Check_Edit_Button:337: error: 'SR' was not declared in this scope
EEprom_Fonction.ino: In function 'void Initialize_EEprom()':
EEprom_Fonction:605: error: 'SR' was not declared in this scope
EEprom_Fonction:609: error: 'SR' was not declared in this scope
EEprom_Fonction.ino: In function 'void Dump_EEprom()':
EEprom_Fonction:687: error: 'SR' was not declared in this scope
EEprom_Fonction:712: error: 'midi' has not been declared
EEprom_Fonction:718: error: 'MIDI' was not declared in this scope
EEprom_Fonction.ino: In function 'void Receive_EEprom(const byte*, unsigned int)':
EEprom_Fonction:758: error: 'midi' has not been declared
EEprom_Fonction:769: error: 'SR' was not declared in this scope
EEprom_Fonction.ino: In function 'void Play_Version()':
EEprom_Fonction:874: error: 'SR' was not declared in this scope
EEprom_Fonction:888: error: 'SR' was not declared in this scope
Interruption_fonction.ino: In function 'void Count_96PPQN()':
Interruption_fonction:16: error: 'SR' was not declared in this scope
Interruption_fonction:21: error: 'SR' was not declared in this scope
Interruption_fonction:70: error: 'SR' was not declared in this scope
Interruption_fonction.ino: In function 'void __vector_7()':
Interruption_fonction:201: error: 'SR' was not declared in this scope
Interruption_fonction:206: error: 'SR' was not declared in this scope
Interruption_fonction:233: error: 'SR' was not declared in this scope
Interruption_fonction:306: error: 'SR' was not declared in this scope
Main_Loop.ino: In function 'void loop()':
Main_Loop:30: error: 'MIDI' was not declared in this scope
Main_Loop:53: error: 'MIDI' was not declared in this scope
Main_Loop:79: error: 'MIDI' was not declared in this scope
Main_Loop:132: error: 'SR' was not declared in this scope
Main_Loop:136: error: 'SR' was not declared in this scope
Main_Loop:165: error: 'SR' was not declared in this scope
Main_Loop:169: error: 'SR' was not declared in this scope
Main_Loop:197: error: 'SR' was not declared in this scope
Main_Loop:201: error: 'SR' was not declared in this scope
Main_Loop:231: error: 'MIDI' was not declared in this scope
Main_Loop:254: error: 'MIDI' was not declared in this scope
Main_Loop:281: error: 'MIDI' was not declared in this scope
Main_Loop:302: error: 'MIDI' was not declared in this scope
Main_Loop:316: error: 'SR' was not declared in this scope
Main_Loop:330: error: 'MIDI' was not declared in this scope
Main_Loop:331: error: 'SR' was not declared in this scope
Main_Loop:351: error: 'SR' was not declared in this scope
Main_Loop:357: error: 'MIDI' was not declared in this scope
Main_Loop:376: error: 'SR' was not declared in this scope
Midi_Play.ino: In function 'void Handle_Clock()':
Midi_Play:131: error: 'SR' was not declared in this scope
Midi_Play:137: error: 'SR' was not declared in this scope
Midi_Play:167: error: 'SR' was not declared in this scope
Midi_Play.ino: In function 'void Check_Midi_Channel()':
Midi_Play:237: error: 'SR' was not declared in this scope
Midi_Play.ino: In function 'void Disconnect_Callback()':
Midi_Play:277: error: 'SR' was not declared in this scope
Midi_Play:278: error: 'MIDI' was not declared in this scope
Midi_Play:278: error: 'midi' has not been declared
Midi_Play:279: error: 'midi' has not been declared
Midi_Play:280: error: 'midi' has not been declared
Midi_Play:281: error: 'midi' has not been declared
Mode_Pattern.ino: In function 'void Mode_Pattern()':
Mode_Pattern:7: error: 'SR' was not declared in this scope
Mode_Song.ino: In function 'void Mode_Song_Edit()':
Mode_Song:7: error: 'SR' was not declared in this scope
Mode_Synchro.ino: In function 'void Mode_Synchro(byte)':
Mode_Synchro:13: error: 'Timer1' was not declared in this scope
Mode_Synchro:14: error: 'Timer3' was not declared in this scope
Utility_Pattern.ino: In function 'void Clear_Pattern()':
Utility_Pattern:13: error: 'SR' was not declared in this scope
Utility_Pattern.ino: In function 'void Copy_Pattern()':
Utility_Pattern:93: error: 'SR' was not declared in this scope
Utility_Pattern.ino: In function 'void Paste_Pattern()':
Utility_Pattern:168: error: 'SR' was not declared in this scope

YELP.....PLEASEEEEE!
User avatar
Masuto
 
Posts: 48
Joined: Oct 10th, '15, 07:32
Location: Venezia

Re: Unoffical Firmware Available

Postby rv0 » Mar 12th, '20, 11:45

Masuto wrote:ok guys.. definitely would like to do it right.

What are you trying?

If it's about using arduino to flash the .hex file on the Yocto, just download the .hex from the releases tab.

If you already have a bootloader you should be able to flash the .syx via midi though

If it's about building the code yourself (to develop...), use the docker setup from https://gitlab.com/jacobvosmaer/yocto-build

Seems like you started out with one single problem and now you have 10 problems :D
Get the latest unofficial Yocto V1 firmware here.
Be sure to check the revised manual.
Leave your comments in this thread.
User avatar
rv0
 
Posts: 184
Joined: Feb 11th, '14, 09:09

Re: Unoffical Firmware Available

Postby Masuto » Mar 12th, '20, 12:42

Thanks for your reply. Since i am unable to transmit the syx via midi, i wanted to try arduino to see if i could do it from there. I burnt the bootloader, but the yocto is non working. No lights, nothing.
I know it’s boring for you to read theough these newbie issues, but really.. it is abit awkward to understand for me-i burnt the bootloader.. and then? How do i burn the unofficial firmware onto the atmega?! Sorry again but maybe this could be useful also to others who cant seem to be able to update to your custom firmware :)
User avatar
Masuto
 
Posts: 48
Joined: Oct 10th, '15, 07:32
Location: Venezia

PreviousNext

Return to Yocto v1.0 Software

Who is online

Users browsing this forum: No registered users and 2 guests