Yocto Expander mode questions

Discuss use it and firmware update

Yocto Expander mode questions

Postby jop808 » Mar 20th, '17, 20:44

Good day,

I'm new to the forum and have build the Yocto thanks to all the great posts and tips here. Almost everything seems fine but have two questions about the expander mode.

* The timing in expander mode seems less tight, if compared when running the Yocto from its internal sequencer. Gear used:
Sequentix Cirklon as master, Yocto in Din sync slave.

I have recorded two files to compare, differences are subtle but noticeable. The 909 kick (Hexinverter clone pcb) is sequenced via the CVIO from the Cirklon.

http://imgur.com/a/xduFN

https://soundcloud.com/living-circuit/yocto-din-sync
https://soundcloud.com/living-circuit/y ... ander-mode

* I cannot trigger the Cymbal in Expander mode, tried all note numbers? Is this a bug or just with mine Yocto...(Cymbal is working fine in other modes)

Hope somebody have some thoughts on these points.

Thanks.
Jop
jop808
 
Posts: 3
Joined: Mar 20th, '17, 20:22

Re: Yocto Expander mode questions

Postby jop808 » Mar 30th, '17, 20:38

No one?
jop808
 
Posts: 3
Joined: Mar 20th, '17, 20:22

Re: Yocto Expander mode questions

Postby rat » Jun 27th, '17, 11:53

make sure you didnt assign an unexpected midi note to it. You can read about how to assign a note for each instrument in the manual. If you still cant trigger the cymbal then something is broken in your build.
rat
 
Posts: 42
Joined: Jun 8th, '16, 14:20

Re: Yocto Expander mode questions

Postby sein83 » Jul 28th, '17, 08:35

Actually i have the same situation in the Expander mode: there is 100% a timing issue, have to adjust the notes in the midi arranger and move them milliseconds off the grid to be on time. Does anyone know when there will be a new firmware with this issue fixed?

thanks in advance!
sein83
 
Posts: 1
Joined: Jul 28th, '17, 08:33

Re: Yocto Expander mode questions

Postby jop808 » Aug 16th, '17, 20:20

Long time not checked here.

The cymbal issue was resolved quite soon via init eprom command, thanks Rat for your feedback, I probably assigned some strange note value indeed.

The timing issue is of course still there, using the Yocto now only via the internal sequencer. Good to know that I'm not alone here having this issue. Hopefully this can be addressed some day together with some other sequencer bugs / improvements. Sound wise I'm still very satisfied with the Yocto.
jop808
 
Posts: 3
Joined: Mar 20th, '17, 20:22

Re: Yocto Expander mode questions

Postby jvq » Aug 26th, '17, 22:05

I made a patch which makes the expander timing a little better I think. http://yocto-e04b97363876c567e1fb.s3.amazonaws.com/data/0001-Improve-MIDI-expander-timing.patch

Experimental firmware: http://yocto-e04b97363876c567e1fb.s3.amazonaws.com/data/yocto-jvq-102a3ac669ccea6208135bdb3ee3f6cc3ac2423a.syx

jop808: maybe you can give this firmware a try.

I think the patch changes the pulse length for the external triggers in midi expander mode, so I would not call it 'finished' yet.

The idea of the patch is to check the value of MIDI.read(), because the MIDI library reads only 1 byte at a time. But I made so many other changes that I don't know which of them made the difference, if any.
jvq
 
Posts: 78
Joined: Aug 17th, '16, 21:36


Re: Yocto Expander mode questions

Postby jvq » Aug 28th, '17, 21:30

jop808 pointed out to me that the volume of the instruments was wrong in my latest patch. I realized I messed up the length of the instrument trigger pulses; those need to be more than 1ms.

Here is a new patch which fixes the volume. http://yocto-e04b97363876c567e1fb.s3.amazonaws.com/data/jvq-d81623ec238e2b70aa920e28113faa83195fc3c8.diff

Sysex: http://yocto-e04b97363876c567e1fb.s3.amazonaws.com/data/jvq-d81623ec238e2b70aa920e28113faa83195fc3c8.syx
jvq
 
Posts: 78
Joined: Aug 17th, '16, 21:36

Re: Yocto Expander mode questions

Postby jvq » Aug 30th, '17, 19:19

I heard from jop808 that the timing is better now.

Here is a release: https://gitlab.com/jacobvosmaer/yocto-firmware/tags/jvq-v1.0.0

Edit: jvq-v1.0.0 is broken (wrong MIDI config). Fixed in https://gitlab.com/jacobvosmaer/yocto-f ... jvq-v1.0.1.
jvq
 
Posts: 78
Joined: Aug 17th, '16, 21:36

Re: Yocto Expander mode questions

Postby gihaume » Dec 8th, '17, 14:01

Did someone measured how better is the timing with the updated expander mode ?

With the original firmware when checking the waveforms of my recordings, the jitter was maximum ~1.5ms, which is not less good than with my other modern drum synths... and the MIDI output from my tight sequencer didn't only send messages for the Yocto, but also other ones for other machines but on a same MIDI cable.

EDIT: or by timing it was meant time response ? I measured ~4.5 ms in original firmware.
gihaume
 
Posts: 245
Joined: May 12th, '14, 14:48


Return to Yocto v1.0 Software

Who is online

Users browsing this forum: No registered users and 2 guests