Cannot update firmware [SOLVED!]

Discuss Yocto construction and related issues

Cannot update firmware [SOLVED!]

Postby Teef » Apr 4th, '18, 02:58

I'm having issues updating firmware. Pressing 1,3,5 while powering makes all 16 sequence lights blink twice, however when I upload sysex to it nothing happens. Not a single indication of it even hearing it. My NAVA updates just fine, so I know it's not an issue with MIDI-OX or how I'm sending the sysex file. Any ideas as to why I would have an issue updating? I didn't program the chip, it was something that came with the kit. Do you think it's worth attempting to flash the atmega with the bootloader again and start over? Maybe I'm missing something else? Would appreciate input as the latest unofficial firmware fixes a ton of bugs that make the instrument really usable. :cry:
Last edited by Teef on May 9th, '18, 15:53, edited 1 time in total.
Teef
 
Posts: 32
Joined: Feb 12th, '16, 21:27

Re: Cannot update firmware

Postby helectromagneticus » Apr 27th, '18, 06:28

Does MIDI I/O work on your Yocto? The fact that the LEDs flash twice suggest that the Yocto bootloader is running.
User avatar
helectromagneticus
 
Posts: 71
Joined: Oct 26th, '16, 02:55

Re: Cannot update firmware

Postby Teef » May 1st, '18, 02:48

MIDI I/O works just fine.
Teef
 
Posts: 32
Joined: Feb 12th, '16, 21:27

Re: Cannot update firmware

Postby helectromagneticus » May 6th, '18, 00:43

In that case, I suggest that you re-flash the bootloader. The are instructions in are in this thread:
viewtopic.php?f=17&t=436
User avatar
helectromagneticus
 
Posts: 71
Joined: Oct 26th, '16, 02:55

Re: Cannot update firmware

Postby Teef » May 9th, '18, 04:27

Dismantled the whole thing, soldered in a connector for an old USBtiny I made years ago for Shruthi. Flashed the bootloader with AVRdude. Firmware updated just fine... pain in my ass.
Teef
 
Posts: 32
Joined: Feb 12th, '16, 21:27


Return to Yocto v1.0 Hardware

Who is online

Users browsing this forum: No registered users and 6 guests